Log In     Register    

Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

fopnu keeps hanging

by Guest on 2019/04/12 12:34:58 PM    
here is a process dump of the hanged state
hope you can fix this
Thanks

(removed by mod and sent to devs)
by Guest on 2019/04/13 04:24:12 AM    
What OS? What version of Fopnu?

are you doing anything when the hanging happens?

any other details that might help?
by KH on 2019/04/14 06:18:28 AM    
Thanks for the dmp file.

Just to clarify, by hanging, you mean the program stops responding until you force it closed, or just for a few seconds at a time?  If you let it sit for a minute or two, will it ever come back?  Does your CPU run at 100% during this time, or pretty much idle?

I looked at the stack in the dump file, and it's inside ntdll in a plain close() function, when the UPNP router discovery socket is closing.  I haven't seen this before, and the UPNP implementation is shared with Tixati, so it's running on a lot of machines.  Just to be sure I examined the code to see if anything looked strange, but didn't see any problems.

If it keeps hanging like this in version 1.32, which will be out in a matter of days, please post another dump file and we'll see if it's in the same exact spot, or maybe it will show there to be a local loop that I'm missing.

In the meantime, a work-around might be to disable UPNP (and manually port-forward on your router if you need to.)
by Guest on 2019/04/14 09:59:58 AM    
its actually worse then that fopnu hangs and no matter what I do I can not force close it with taskmanger or console it just turns into a zombie with 0% cpu used an no threads running (checked with sysinternals process explorer) with fopnu in this state I noticed that foobar2000 starts behaving strangely/crashing, I assume thats because it uses upnp too
so far restarting the pc is the only fix

yes it also hangs on a freshly restarted pc with nothing else running

I also use tixati lot  and never encountered this even running it several days straight

I've always been manually forwarding ports automatic forwarding is turned off on the router  I just never bothered turning upnp off

turning off upnp seems to have worked no hang so far




This web site is powered by Super Simple Server