Log In     Register    

Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

Selected Port not working - UPnP fails too

by BugMagnet on 2019/08/06 12:52:41 PM    
I set a specific static port in my fopnu config. (v1.34 on windows 7, wifi connection)

I had a rule for UDP port forwarding the fopnu port. I also had UPnP enabled in both fopnu and my modem/router firewall.  But I am seeing me with a different port online, the system default to 1024.

Maybe it's the heatwave that fried my brain. I can't see why this is happening.

[11:44:40 AM]  Welcome to Fopnu v1.34
[11:44:40 AM]  Loading saved configuration files...
***
[11:44:41 AM]  Configuration file loading complete
[11:44:41 AM]  Loading user interface...
[11:44:42 AM]  Initialization complete
[11:44:43 AM]  Network starting
[11:44:43 AM]  Listening on udp:0.0.0.0:12345
[11:44:43 AM]  Listening on udp:[::]:12345

[11:44:46 AM]  New location set: 1.2.3.4:1024 <<<<<<< ????????  Why 1024?

[11:44:57 AM]  NAT-PMP mapping UDP port 12345 on gateway 192.168.1.1 > socket error waiting for reply: Timed out (50434)
[11:44:58 AM]  UPNP mapping UDP port 12345 on gateway 192.168.1.1 > command failed with error 402 Invalid Args
[11:44:58 AM]  Mapping UDP port 12345 on gateway 192.168.1.1 will be retried every 5 minutes

I see some changes were made in v1.34 related to UPnP. But if I have a static port forwarding rule in the modem/router firewall to pass the fopnu port I selected I shouldn't even need UPnP right?.

I removed my firewall rule, to test UPnP without it. Both UPnP and NAT-PMP mapping fail.

The options I have for UPnP in my router are:
UPnP: ENABLE/disable
Advertisement time: 300 (seconds)
Advertisement Time to Live: 4 (hops)
IGD/NAT-T: ENABLE/disable

I turned the router firewall and DOS protection off completely. I made a rule to port-forward my fopnu UDP port. I am still using port 1024 after restarting fopnu.

The options for the router rule include:
Global port range: 12345 to 12345
and
Local base port: 12345

would that be right?


What am I missing?
by BugMagnet on 2019/08/06 02:41:49 PM    
What am I missing?

Oh.  Windows.

I rebooted the router...again. Then my computer. It seems rebooting the computer changed something and fopnu was then using the port I configured for it, not 1024.

I hadn't rebooted the system in weeks. Would not have even looked at the port until another user who was also having channel disconnect issues told me I was on port 1024. I had noticed he was also on a 10XX port on both his systems.

If we blame it on windows, maybe case solved.  dunno.
by Guest on 2019/08/07 02:39:52 AM    
I noticed similar behavior.

I have port 49999 selected. It is open - I have verified the port is open not only in Tixati, but https://www.yougetsignal.com/tools/open-ports/

When I then select this port for fopnu, the link above states the port is CLOSED.

Yes, the port is forwarded for UDP connections.




This web site is powered by Super Simple Server