Log In     Register    

Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

UDP port translation

by Guest on 2020/06/12 05:45:32 AM    
Hello, I am a noobie here and I am puzzled by a message which appears on the "Network" tab. It comes up as :-

Online (NAT)
UDP port translation detected, press f1 for help.

I have pressed f1 but am none the wiser. My question is, is "UDP port translation detected" good or bad?

As a supplementary is there such  thing as a user guide for fopnu?
TIA

by Guest on 2020/06/13 11:29:22 PM    
It means you haven't port forwarded. You can't receive inbound connections without Fopnu using NAT traversal. Fopnu can automatically port forward for you if your router supports it. (almost every router does)

There's two reasons why Fopnu was not able to automatically port forward:

1) Your router doesn't support UPnP / NAT-PMP. If this is the case you can manually port forward if you give your computer a static (LAN) IP. Some routers support DHCP reservations for this. After you setup the DHCP reservation or static IP, you can create the port forwarding rule from your router's webUI. If you don't know how to access your router's webUI, open command prompt or powershell and run the "ipconfig" command. Enter the default gateway IP in your browser. Common examples are "http://192.168.2.1/" and "http://192.168.1.1/". For the port forwarding rule, keep it as a 1:1 (one to one) rule. What I mean by that is if UDP port 43857 is the port your Fopnu uses, then the rule would use that for this port on router's public IP and LAN side. Example:  WAN UDP port 43857 to LAN 192.168.2.250 UDP 43857. Your port number and LAN IP will almost certainly be something different. This is just an example. I'll send a screenshot example later.

2) Your ISP uses something called carrier grade NAT (CGNAT). It's also known as large scale NAT or NAT444. You'll have to ask your ISP about this. You can't port forward from your router so you'll have to ignore this or use a VPN. I also recommend checking to see if your ISP supports IPv6. You can go to https://ipv6-test.com/   If your ISP supports IPv6, you do not have to configure port forwarding for IPv6. IPv6 doesn't use NAT or CGNAT like IPv4.

You can still use Fopnu without port forwarding but if you are able to it's always recommended to do so.
by Guest on 2020/06/14 06:31:36 PM    
port forward rule example: https://postimg.cc/zH8pYRZ0

Make sure to click apply or save.
by Guest on 2020/06/15 04:40:16 PM    
Thank you both for your replies.

I have not made any config changes, but since my post I have not had the UDP port translation message.
If it makes any difference, I have UPnP enabled on my router and I am connecting thru' VPN. I don't have IPv6 enabled at the moment but might first try making a port forwarding rule.
by Guest on 2020/06/17 11:22:47 PM    
If you're using a VPN, you do not have to configure any port forwarding on your home router. Your VPN provider may have disabled IPv6 because they don't support it. My VPN provider disables IPv6 on all interfaces if IPv6 leak protection is on. You VPN provider might support automatic port forwarding(UPnP) and that's why you no longer see that message.




This web site is powered by Super Simple Server