Log In     Register    

Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

Too slow reconnection after network disconnection

by Guest on 2019/09/17 08:21:54 PM    
After my internet connection or VPN disconnects, Fopnus is too slow to reconnect to the network. Not just too slow, but actually extremely slow. Network reconnection seemed to be faster in older versions but don't remember the exact version this problem appeared. I run 1.37
by Guest on 2019/09/30 08:37:17 AM    
what OS?

have you tried v1.39? is it working better for you?
by Guest on 2019/10/01 12:26:55 PM    
Win 10, 64bit. Tried 1.39 and the problem still exists..
by Guest on 2019/10/27 12:33:21 PM    
Discovered new details about the problem (Fopnu 1.39, Win10-64): When the router loses the internet connectivity a VPN Windows app I use blocks the PC from internet traffic and tries to reconnect to the VPN. But if the VPN reconnects, Fopnu fails to connect to the Fopnu network. But if I manually disconnect from the VPN and then manually reconnect, Fopnu immediately connects to the Fopnu network. Similarly, if after the router loses connection and the VPN app blocks internet traffic I manually unblock it and then manually connect to the VPN then Fopnu connects normally too. I don't know if the problem is caused by Fopnu itself or from the VPN app. My Fopnu is configured to only connect through the VPN connection. But this problem did not exist in the past, I think it started after I updated Fopnu to some recent version (before 1.37). However, in the mean time I've installed updates to the VPN app and also Win10 updates, so the problem could be due to any of these (Fopnu, VPN, or Win10).
by Guest on 2019/10/29 12:11:03 AM    
This topic might be part of the same issue

https://forum.fopnu.com/support/268

The symptoms are pretty much the same I believe in that traffic or connectivity is lost and a port change or restart (anything that closes and reopens the socket) resolves the issue.

My suggestion is to try port forwarding or ensure UPNP is working ok wth your router.

/me crosses fingers.
by Guest on 2019/11/01 05:40:04 PM    
I solved the problem! (1.39 on Win10-64), I went to Settings -> Network and enabled random port change every 1 hour, now Fopnu immediately reconnects to the network and works perfectly well with the VPN app no matter how often the router loses internet connectivity.
by Guest on 2019/11/03 02:40:55 PM    
Bravo : ))

Thank you for returning to share this knowledge with the rest of us, ISP companies are often annoying but with the help of the developer and our own efforts we shall prevail.




This web site is powered by Super Simple Server